Close

fastdep

release
stars
fastdep
Apache License, Version 2.0

Github 项目地址:https://github.com/louislivi/fastdep (支持请点Star)

设计初衷

你是否也发现Spring Boot集成一些依赖时过于复杂, 需要重写或者建立一些java配置类进行配置, 有些多个依赖同时集成还易出现各种兼容性问题, fastdep只需要引入一个依赖就可以解决你的这些问题。

后续还会继续开发更多的依赖集成有兴趣的coder可以贡献你的代码让集成依赖更加的方便。

快速开始

如果你想使用fastdep,你需要:

  • Java 1.8+
  • Spring Boot 2.0+
  • 引入依赖
  • Maven
<dependency>   
<groupId>com.louislivi.fastdep</groupId>   
<artifactId>${模块名称}</artifactId>   
<version>latest-releases</version> 
</dependency>
  • Gradle
compile group: 'com.louislivi.fastdep', name: '${Module Name}', version: 'latest-releases'

模块

模块名称描述引入的依赖
fastdep-datasource多数据源jta+druid+mybatis
fastdep-redisRedis多数据源redis+redisTemplate

协议

Apache Licence v2

Leave a Reply

Your email address will not be published. Required fields are marked *